comment section

gvdunk's Avatar

gvdunk

25 May, 2020 01:06 PM

Frequently when I'm reading comments, a new comment comes in and all of a sudden I've lost my place.

I suspect this is something that I must endure, but starting now when this happens I'll close the tab and move on.

Just too frustrating for me.

  1. Support Staff 1 Posted by Daily Kos Staff on 26 May, 2020 07:10 PM

    Daily Kos Staff's Avatar

    Hello, and thanks for reaching out to us. Sorry for the awkwardness you're experiencing.

    We do know that problem is an issue still with our so-called "Lazy Comments," implemented last year. We have a ticket in the queue to address it, and we'll get to it as soon as possible.

    There are two workarounds in the meantime. One is to turn OFF your auto-refresh setting for comments; having it OFF seems to lessen this jumping. To change it, look for the light gray link Comment Settings at the bottom of every post/top of the comments. Click it, then UNclick the box next to Auto refresh. The black box indicating new comments on a post while you are reading it will no longer slide into view as long as you have this setting turned OFF. Any time you clear your cookies for the site, however, please note that the setting will default to ON.

    The other is more far-reaching but similarly reversible. Assuming that you have simply gone to https://www.dailykos.com you are loading the "new" comment style by default. You may choose to view the OLD style comments if you'd like, for the time being. The comments will look somewhat different but the functionality remains the same in many, though not all, ways.

    There are two ways to change this display. To set the display of ALL comments in EVERY story to be in the OLD mode, go to this variation of the home page URL: https://www.dailykos.com/comments_beta/false

    Using this global true/false is the easiest way to switch. But there is also a way to change the comment display mode on individual stories. To do so requires a little more precision in altering a story URL.

    To have an individual story display its comments in the NEW mode, add this string to the end of the story URL: ?new_comments=false Changing the setting for an individual story will not affect whatever you have for the global setting. (The reversal of this setting is of course to replace true with false.)

    There is a little wrinkle to know if you wind up needing to switch a non-Front Page story to show the OLD comments. If a Community story has gained enough recommendations, it may have another little string starting with a ? after the story title. Don't worry about it; you can still append the ?new_comments=false string to the very end. Just make sure you don't cut off any of the URL before you stick that part on.

    To undo this setting, the global URL = https://www.dailykos.com/comments_beta/true
    while the string to add to the end of an individual post = ?new_comments=true Or, clear your cookies for the site, since the new comments are the default style now.

    Hope this helps! I can't say how much longer it will be until we can improve that jumpiness, unfortunately.

    Thanks for your understanding, and thanks for joining the site.

  2. Daily Kos Staff closed this discussion on 26 May, 2020 07:10 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac