destination URLs not displaying for some versions of Firefox

Pariah Dog's Avatar

Pariah Dog

17 Apr, 2020 02:10 PM

Ever since the latest update from Firefox, I've noticed that the destination URL of links no longer displays in the lower L/H corner of my screen. Sometimes, if I move my cursor juuuust right, it will flash very briefly, but over all I click a link without having the faintest idea where it's leading me. I find this annoying.

First thing I did was turn off the "enhanced tracking protections" for the site because I've also had major problems with this FF feature before. Not surprisingly the destination URLs appeared like normal. But the page also became covered with ads. I use ABP, and that remained on, so all those ads should have stayed blocked, but they didn't.

Second experiment, since I also have a stone age version of IE on my comp, I opened DK in that browser and every link I pointed to gave me a destination URL right where it's always been. So I've determined that this is something FF did with the last update. Another odd thing. I downloaded a FF update about a week and a half ago. Then two days later that aggravating pop up of theirs announced another one. It's just been since that second one that the problem started.

Anyone else running FF having this issue?

  1. Support Staff 1 Posted by Daily Kos Staff on 21 Apr, 2020 01:01 AM

    Daily Kos Staff's Avatar

    Hello, and thanks for asking.

    I've not seen any comments from folks on your ticket, but I'll leave it open for a while to see if someone does reply. I edited your subject line in case that draws more eyes.

    Which version of FF are you using exactly? And on Mac or PC? FF has indeed been ramping up their security features. But at the moment I have the standard, not the strict, setting on and the links do display, for what it's worth.

  2. 2 Posted by Pariah Dog on 21 Apr, 2020 06:46 PM

    Pariah Dog's Avatar

    Thanks for leaving this up. Strange that no one else has this problem. I'm running FF 75.0.

    I'm thinking of trying to delete that second update that came so fast on the heels of the one before because I have a strange feeling that's the one that did something.

    Oh, and when I disabled the enhanced protections thing the second time, I noticed it wasn't ads per se that appeared. It was links to Taboola, Google Ad Services, etc.

  3. 3 Posted by Pariah Dog on 21 Apr, 2020 06:49 PM

    Pariah Dog's Avatar

    Oh, finish reading the comment before replying PD. I'm running Windows 7. I'll try lowering my settings for the protection thing. Anyone that wants to track me is going to be mighty bored anyway.

  4. Support Staff 4 Posted by Daily Kos Staff on 21 Apr, 2020 08:33 PM

    Daily Kos Staff's Avatar

    OK cool. Could be an issue of the combo of Win 7 and newer FF, too, maybe (?) I can look on a virtual machine though that might not permit enough scope for replication.

  5. 5 Posted by RosyFinch on 15 May, 2020 05:10 AM

    RosyFinch's Avatar

    Safari Version 12.1.2 (12607.3.10) on my iMAC I don't see the link's address.
    Yes, I'm running Adblock Plus Protection

  6. 6 Posted by Pariah Dog on 14 Jul, 2020 06:40 PM

    Pariah Dog's Avatar

    Hey there anyone who is still watching this. A few days ago, I downloaded yet another FF update. First thing I noticed was that the destination URLs are displaying again. So we can go ahead and close this if you want. TY

  7. 7 Posted by RosyFinch on 14 Jul, 2020 06:55 PM

    RosyFinch's Avatar

    I agree. Fixed

    Thanks

    > Anne Fuller

    “If more of us valued food and cheer and song above hoarded gold, it would be a merrier world” J.R.R.Tolkein

  8. Support Staff 8 Posted by Daily Kos Staff on 14 Jul, 2020 07:05 PM

    Daily Kos Staff's Avatar

    Oh thanks much for the update! We definitely like knowing that an issue like this has been successfully resolved.

  9. Daily Kos Staff closed this discussion on 14 Jul, 2020 07:05 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac