Comments

Chxmi's Avatar

Chxmi

23 Jan, 2020 04:17 PM

Can someone please assist. I cannot read any of the comments for Mark Summers diaries. I don’t have this issue for any other diary and wonder how to remedy this situation. I see the comment settings but don’t know which options to choose to let me see the comments. I’ve tried various combinations but have no luck. Thanks

  1. 1 Posted by scyellowdogdem on 23 Jan, 2020 05:18 PM

    scyellowdogdem's Avatar

    CHXmi - You're not the only one. There are two other open tickets on this issue. I am also one of the people who cannot read comments in Mark's (and only Mark's) diaries. Apparently it has something to do with the old comment format, which I use and will continue to use as long as they let me. Hopefully, someone can figure this out but so far it appears to be switch to the new comments or give up on commenting in Mark's diaries.

  2. 2 Posted by nilso on 23 Jan, 2020 06:48 PM

    nilso's Avatar

    And I cleared my Safari cache, tried to post a comment on genec's diary today (the one with a poll about mocking Trump supporters). No comment box shows for me, at all, top or bottom. This has happened the last few days for what appear to be random diaries, and not for others. I have not been banned.
    So, what's going on?
    Thanks!

  3. Support Staff 3 Posted by Daily Kos Staff on 23 Jan, 2020 08:15 PM

    Daily Kos Staff's Avatar

    Thanks, everyone.

    Very sorry that we don't yet have a diagnosis. But there is an easy workaround (easy, that is, if you can tolerate the new comments mode). Two workarounds, actually: one that is global, for all stories on the site, and one that is particular to a given story.

    To set the display of ALL comments in EVERY story to be in the new mode, go to this variation of the home page URL: https://www.dailykos.com/comments_beta/true As you know, this is now the default display, but if you're loading old-style comments routinely now at some point you went to this version instead: https://www.dailykos.com/comments_beta/false

    Using this global true/false is the easiest way to switch. But there is also a way to change the comment display mode on individual stories. To do so requires a little more precision in altering a story URL.
    To have an individual story display its comments in the NEW mode, add this string to the end of the story URL: ?new_comments=true
    Thus, after you add that string, a URL from one of today's stories by Mark Sumner will look like this:
    https://www.dailykos.com/stories/2020/1/23/1913464/-Trump-s-trial-day-one-A-masterclass-from-House-Democrats-and-empty-seats-from-Senate-Republicans?new_comments=true Changing the setting for an individual story will not affect whatever you have for the global setting. (The reversal of this setting is of course to replace true with false.)

    There is a little wrinkle to know if you wind up needing to switch a non-FP story to show the NEW comments. If a Community story has gained enough recommendations, it may have another little string starting with a ? after the story title. Don't worry about it; you can still append the ?new_comments=true string to the very end. Just make sure you don't cut off any of the URL before you stick that part on.

    We have a lot going on lately but we'll see if we can figure this out sooner than later. Thanks for your understanding, and apologies for the inconvenience.

  4. Daily Kos Staff closed this discussion on 23 Jan, 2020 08:15 PM.

  5. nilso re-opened this discussion on 23 Jan, 2020 08:24 PM

  6. 4 Posted by nilso on 23 Jan, 2020 08:24 PM

    nilso's Avatar

    So, is there some reason why, when I go to ~beta = true, I'm redirected in
    about 1 second to this vanilla URL:

    https://www.dailykos.com

    which has neither flag?

    AND, actually, I was unaware that there was a new, default comments mode.
    Where can I read more about that??

    Thanks,
    Nils

  7. Support Staff 5 Posted by Daily Kos Staff on 23 Jan, 2020 09:59 PM

    Daily Kos Staff's Avatar

    Thanks, nilso, for the follow-up questions.
    Once that toggle is set there's no reason for the site URL to display anything more than the basic home page. That little string is simply an on-off button (depending on true/false) that triggers a cookie for your browser.
    This post by elfling from last spring explains the change in detail, with links to previous stories providing details about the process along the way.

  8. Daily Kos Staff closed this discussion on 23 Jan, 2020 09:59 PM.

  9. nilso re-opened this discussion on 24 Jan, 2020 09:25 PM

  10. 6 Posted by nilso on 24 Jan, 2020 09:25 PM

    nilso's Avatar

    Hi,
    Thanks for the quick reply. But I still don't know how I can confirm that
    when I go to DKos website, the ~_beta version is loading *by default,* which
    is what I want. Any advice on that?

    Thanks,
    Nils

  11. 7 Posted by nilso on 24 Jan, 2020 09:46 PM

    nilso's Avatar

    Just to confirm I am still having this problem, specifically with a Laura
    Clawson diary which has no visible comment boxes. Note- I think most of the
    time this has happened with Staff diarists like Clawson.

  12. Support Staff 8 Posted by Daily Kos Staff on 24 Jan, 2020 10:06 PM

    Daily Kos Staff's Avatar

    Thanks. Well, you can certainly look at the comment display to see which ones show up. Otherwise, no, the URL will not generate or display any information to show what you have. If you clear your cookies for the site, you'll be returned to the default state, which is new (beta) comments ON.

    We are actively investigating the bug though we haven't yet pinned down the cause.

  13. 9 Posted by nilso on 24 Jan, 2020 11:50 PM

    nilso's Avatar

    Hi, I just edited the URL for my Kos bookmark to include the "beta", and
    should be fine now (I'll let you know if not).
    -Nils

  14. Support Staff 10 Posted by Daily Kos Staff on 27 Jan, 2020 04:23 PM

    Daily Kos Staff's Avatar

    Excellent. Our QA team did track down the cause and we have a ticket in the works for a fix. I don't yet know how soon it will be implemented but I expect the wait to be relatively short.
    Thanks for your patience in the meantime.

  15. Daily Kos Staff closed this discussion on 27 Jan, 2020 04:23 PM.

  16. nilso re-opened this discussion on 27 Jan, 2020 04:36 PM

  17. 11 Posted by nilso on 27 Jan, 2020 04:36 PM

    nilso's Avatar

    Thank YOU!
    -Nils

  18. Moderator1 closed this discussion on 27 Jan, 2020 06:08 PM.

  19. nilso re-opened this discussion on 27 Jan, 2020 09:45 PM

  20. 12 Posted by nilso on 27 Jan, 2020 09:45 PM

    nilso's Avatar

    Sorry to say the problem has recurred again today, with the interesting
    fact that the diary in question is by Hunter, who is dKos staff. I think
    this problem has occurred for me mostly or always with dKos staff diaries.
    Is there a permission-thing of staff-posted diaries that could be quietly
    causing this problem for me?
    Thanks very much,
    Nils

  21. Support Staff 13 Posted by Daily Kos Staff on 27 Jan, 2020 10:12 PM

    Daily Kos Staff's Avatar

    Hello. I think there was a miscommunication. We know what exactly is causing the problem. We have not yet fixed the bug, though we should soon. Sorry--till the fix is indeed complete, you will encounter it on some posts. Staff status is not the issue.

  22. 14 Posted by nilso on 27 Jan, 2020 10:41 PM

    nilso's Avatar

    Thanks again for the clarification!

  23. 15 Posted by nilso on 27 Jan, 2020 10:50 PM

    nilso's Avatar

    Oh, and one more thing, hitting "reload" on the webpage sometimes works to
    make comments available- if this info helps.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac