Something's All Screwed Up! (on newest Firefox)

Timaeus's Avatar

Timaeus

27 Oct, 2019 10:21 PM

I just installed the latest Firefox update (don't know if that's related). Then when I went to DKos I get a very incomplete screen. No access to my profile. No login button. The front page is accessible, and the reclist, but no other diaries. The site is not usable in this state.

I remembered that I had T&R'd the top diary on the reclist. I went to that diary and the diary itself appeared, but not the comments. By clicking on my name in the list of recs, I confirmed that my profile still exists and I'm still a TU and I could get to the list of hidden comments (I didn't check if I could read the hidden comments).

  1. 1 Posted by Eyesbright on 28 Oct, 2019 12:06 AM

    Eyesbright's Avatar

    Just for information purposes: I installed that newest version of Firefox (v. 70.0) a couple of days ago and haven't had problems of any kind. I'm still using Windows 7 and that may make a difference.
    Good luck, Timaeus! I hope it straightens out for you really soon!

  2. 2 Posted by Timaeus on 28 Oct, 2019 12:16 AM

    Timaeus's Avatar

    Hi. I'm pretty sure it's not Firefox, and I'm also still using Win7. And yes, I have dumped my cache.

    I think it's a DKos server problem. There were a few threads here recently about people unable to access comments, but I don't recall any complaints about inability to login.

    To sum up, right now:
    --I can see front page posts, but no comments.
    --I can see the reclist posts, but no comments.
    --As I described I found a backdoor way to get to my profile and to the hiddens; but I can see the list of hidden comments, but can't read any of them.
    --I can't see any of the other righthand lists of comments.
    --And I have no login button. Awhile back, after dumping my cache, I went to DKos and lo and behold the login button was back. I hit it to login, and the site remembered by UID and PW. But when I hit that, everything just reverted to the mess just described. For all I know the DKos server still thinks I'm logged in. The Help Desk seemed to recognize me.

    Shocking to witness how addicted I stilll am to DKos after almost 16 years.

  3. Support Staff 3 Posted by Daily Kos Staff on 28 Oct, 2019 02:06 PM

    Daily Kos Staff's Avatar

    Hello, Timaeus, and sorry that you're having difficulty accessing the site.

    It's helpful that you cleared your cache already, but there's another key diagnostic step that you can take. Please open the site while you are on a private window to see how it behaves. Generally, private windows disable any extensions or add-ons your browser has, so it's a good way to determine whether anything extra on your browser is interacting badly with the site.

    We'll be watching for your reply.

  4. 4 Posted by Timaeus on 28 Oct, 2019 06:17 PM

    Timaeus's Avatar

    Thanks for quick reply. I've never used a private window before, and I'm pleased to see that that has returned things to normal! But I don't think I want to keep doing everything in a private window.

    I haven't added any browser extensions or add-ons recently, so I suppose some website pushed something down on me.

    Do you have any clues on how I might isolate the offending code?

  5. Support Staff 5 Posted by Daily Kos Staff on 29 Oct, 2019 04:19 PM

    Daily Kos Staff's Avatar

    Thanks for the update; I'm mostly pleased that you had good results from the test, but of course still interested in pinning down the source of interference.

    On Firefox, you have a menu option Tools in the top toolbar. When you click it, you'll see the option to go to Add-ons. Once you're there, you'll see whatever add-ons you do have enabled, and you'll also see an option to display the extensions you have as well.

    Generally, we don't provide browser-specific support, but it is possible that the latest Firefox version is including something that doesn't play well with the site. That is still to be determined, however, since for many users the site seems to be working just fine with it.

    This ticket is public, so other folks having Firefox-specific issues may weigh in. I will edit the subject line to see if folks find it and join the conversation. The user forums sponsored by Mozilla often have good information related to new versions, applicable across the board, and you might find them helpful in the meantime.

    For now, we remain in the info- and evidence-gathering phase.

    Thanks for your support of the mission of the site.

  6. 6 Posted by zane (unverifie... on 30 Oct, 2019 05:40 AM

    zane's Avatar

    on my desktop and laptop, I get the mobile site.

  7. 7 Posted by sagesource (unv... on 30 Oct, 2019 03:36 PM

    sagesource's Avatar

    I am having the same problems as described here. They began after I ran Avira's startup speedup program, which seems to delete just about everything it can find (it completely wrecked my Discord, for one). I'm not sure how to run Firefox in a private window.

  8. 8 Posted by Timaeus on 31 Oct, 2019 12:58 AM

    Timaeus's Avatar

    @sagesource, you can open a private window in Firefox by going to the three-lines-on-top-of-one-another icon at the upper right of the Firefox home page; select "Open Private Window." Be sure to read the link about myths about private browsing.

    Mysteriously, I now have a very similar problem with my work computer. Both computers are running Win7 and the latest Firefox. But now suddenly today my work computer can't get ANYWHERE unless I open a private window, which does work.

    Very mysterious.

    I appreciate very much the help from DKos mods, but it seems like too much work at the moment, since the private window fix is working, at least for the moment. I do intend to get to that! Thanks again!

  9. 9 Posted by G. Arbuckle (un... on 31 Oct, 2019 01:32 AM

    G. Arbuckle's Avatar

    Thank you very much for this information.
    S.

  10. 10 Posted by jmrichardson on 31 Oct, 2019 11:32 AM

    jmrichardson's Avatar

    I use an IPad 2 to access this site and since yesterday afternoon have the same problems as described above. I'm only getting the front page headings, with no writing or comments and nothing under recommended or recent. I'm not sure I understand the described fixes.

  11. 11 Posted by G. Arbuckle (un... on 31 Oct, 2019 02:27 PM

    G. Arbuckle's Avatar

    It appears that Firefox will play nice if you open it in a so-called
    private window.
    Go to the upper right hand corner of the screen and click on the icon that
    looks like three sheets of paper stacked.
    Choose the option "New Private Window."
    Sign into Kos through this.

  12. Support Staff 12 Posted by Daily Kos Staff on 31 Oct, 2019 07:44 PM

    Daily Kos Staff's Avatar

    Hello again, and thanks for the updates. Here I am going to provide information regarding Firefox only, and not discuss Safari issues, because there are other public tickets open for Safari/iPad.

    I am not positive, but I suspect that what might have happened for those who recently had the new version of Firefox installed is described in this resource: https://support.mozilla.org/en-US/kb/extensions-private-browsing
    It appears that now a user must explicitly choose which extensions will operate while in private browsing mode. I'm inferring that even if you made that choice with an earlier Firefox version you would have to make it again now. That would mean whatever extensions get applied automatically with the newest Firefox are not activated while in private mode.

    I've just updated my own Firefox and do not have a site conflict--but for obvious reasons, I run a plain version, no extensions. So that's the suggestion I'd make about where to look for conflicts: in your current extensions, to see whether they need to be disabled for the new version.

    We'll be interested in hearing what you report next.

  13. 13 Posted by Skookum on 01 Nov, 2019 01:27 AM

    Skookum's Avatar

    Same problem as everyone else, all headers, no diaries, no comments, no login except here in Help. I'm using Win7 & FireFox 67 on an admittedly older computer, have done NO recent updates; one of our new laptops (Win 10/FF68) is also affected. Clearing the cache & using a private window doesn't work. This is the ONLY site I've been to that has this problem (&, as I said, we've done NO recent update) so I'm considering it a DailyKos fail, not a FireFox fail. Unfortunately I just haven't the time to play with it any further right now -- I'm adding this to the discussion just for your information as I suspect there are plenty of other kossacks who are having the same problem but aren't computer or site savvy enough to even get THIS far (& logged in). I'll check back now & again to see if it gets resolved but in the meantime I'm taking it as a message from the Universe that I need to spend less time on DK & more in the Real World! For now, I guess it's so long & thanks for all the fish :-)

  14. Support Staff 14 Posted by Daily Kos Staff on 01 Nov, 2019 01:35 AM

    Daily Kos Staff's Avatar

    Hey, Skookum, thanks for the input. No doubt you are correct that many more people are affected besides those who come to Helpdesk to report it. We'll continue to see what we can figure out as a possible cause. It might not be our "fail" as much as a mutual incompatibility. We'll keep the thread open for the sake of continued problem-solving.

  15. 15 Posted by bigjacbigjacbig... on 01 Nov, 2019 03:41 AM

    bigjacbigjacbigjac's Avatar

    Hey, me too:
    "Same problem as everyone else, all headers, no diaries, no comments, no login except here in Help. I'm using Win7 & FireFox 67 on an admittedly older computer,"
    Me, too.
    Forgot to mention, I am using Comodo Dragon.
    I tried switching to Chrome, same problem.

  16. 16 Posted by bigjacbigjacbig... on 04 Nov, 2019 04:48 AM

    bigjacbigjacbigjac's Avatar

    Also, I tried an incognito window, and that did not help.

  17. 17 Posted by greenbird on 04 Nov, 2019 08:13 AM

    greenbird's Avatar

    win 7, FF.7 was updated a while back
    i'm only noticing 3-line entries when entering new line to type.
    that COULD be default, as i often use
    SHIFT+Enter (as above) to force single-line spacing.
    in this comment box, i find nothing like that, but in the diary comment-boxes, i do.

    enter, at finish of sentence, defaulted to 2-line entries.
    now, it's defaulting to 3-line entries.

    i'm not a diarist, but a frequent short-comment writer, no other probs noticed for now.
    thanks, tekkies, for keeping discussion open, and posters for posting.

    i'll check back when my eyes can read better.

  18. 18 Posted by Timaeus on 12 Nov, 2019 01:47 AM

    Timaeus's Avatar

    I got another Firefox update today, and the whole problem went away. Thank goodness. No doubt I'll never know the reason.

  19. Support Staff 19 Posted by Daily Kos Staff on 12 Nov, 2019 04:13 PM

    Daily Kos Staff's Avatar

    Oh my goodness! Well. I'm definitely grateful for that development. We are close to a resolution for the iPad/iPhone issue, and this was next on my list to investigate.

    I am going to leave this ticket open, though, to permit other folks who weighed in with their own reports of problems with Firefox to comment about their current status. It may remain an issue for some users with slightly different setups.

    Thanks for the update.

  20. 20 Posted by greenbird on 12 Nov, 2019 04:43 PM

    greenbird's Avatar

    my issue was the "enter" key seems to put in several lines,
    instead of just one - or, it's always been that way and i never
    noticed, which makes it "no" issue, i guess.
    i still use "shift"-"enter" to force a single line entry
    bird

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac