I now have to check "email me when people reply to this comment" every single time

Franks Human's Avatar

Franks Human

24 Apr, 2019 11:32 PM

Starting today, here on work computer (HP Desktop, Firefox browser), the "email me when people reply to this comment" (or whatever it says) box has become permanently unchecked so I have to check it for every comment. It had not been that way previously. The few times I had to reset my browser at home (because of that Safari issue that involves your comment updating process), I would check the box and it would then remain checked for my next comment. (Until the comments wouldn't work at all again, at which point I had to clear history, then I'd comment and check that box. After that it would remain checked. That's Safari on my Mac.) On this computer, until today, it always defaulted to the box being checked (because I had set it that way, presumably, in a comment long, long ago).

Is there a way to get it so it just checks as a default again?

  1. 1 Posted by Franks Human on 25 Apr, 2019 04:09 AM

    Franks Human's Avatar

    And beginning tonight the same is true for my Mac at home. Is there any way to adjust it so it will default to checking this box?

  2. Support Staff 2 Posted by Daily Kos Staff on 25 Apr, 2019 05:30 PM

    Daily Kos Staff's Avatar

    Hello, and thanks for asking.
    That is the reverse of how it should behave, for sure. The default state is for it to be checked. So after you clear your cookies for the site, it should revert to default and stay checked unless you change its state.
    Are you using old comments or new?

  3. 3 Posted by Franks Human on 25 Apr, 2019 05:39 PM

    Franks Human's Avatar

    I'm not using the new comments.

    Could you remind me how to clear cookies only for the site? Elfling told me once, but I don't have that handy. (I had been told how to clear my Safari history, but that makes me have to reset all these other websites.)

    At home, it's Safari.
    At work, I use Firefox. There, I may need to have my IT Administrator do anything as I don't always have admin rights for every operation, so if you give me instructions on clearing cookies just for your site in each of those set-ups, I'll try to do so.

    Thank you. And I'm glad the default is remaining `checked.' I was worried that default was being changed across-the-board. Whew.

  4. Support Staff 4 Posted by Daily Kos Staff on 25 Apr, 2019 08:05 PM

    Daily Kos Staff's Avatar

    Yes, clearing cookies site-by-site is preferable to losing everything.

    On Safari, go to Preferences > Privacy then Manage Website Data. Clicking that button will offer you a list of the sites with data stored on your browser, and you can find Daily Kos there. It does NOT seem to be possible to delete ONLY cookies for our site, but at least you'll clear the data (cookies and cache) only for us.

    On Firefox, go to Preferences > Privacy & Security. From there, find the section on Cookies & Site Data, then click on Manage Data. A window will open to display all the sites storing cookies on Firefox, and entering Daily Kos in the search window will bring up our site. On this browser you can clear cookies only, for what it's worth.

    These little secrets ought to be more easily found, I agree.

    I'm ticketing the original issue and we'll see what patterns we can find to help us ID the remedy. Thanks again for asking about it.

  5. Daily Kos Staff closed this discussion on 25 Apr, 2019 08:05 PM.

  6. Daily Kos Staff re-opened this discussion on 25 Apr, 2019 08:25 PM

  7. Support Staff 5 Posted by Daily Kos Staff on 25 Apr, 2019 08:25 PM

    Daily Kos Staff's Avatar

    Let me ask one more thing, actually. Have you made any changes to YOUR setups? Any browser updates, any changes in add-ons or extensions? It is important for me to double-check that nothing has changed on your end. Thank you.

  8. 6 Posted by Franks Human on 25 Apr, 2019 09:15 PM

    Franks Human's Avatar

    No, I haven't made any changes to either settings (on my Mac, or the work computer) between when it was working and the next day when it stopped working).

    And an update: On the work computer, with Firefox, I just followed your directions above and just left comments in PWB Peeps to test. In the first comment I checked the (unchecked) box, and then I hit reply and the box in the new comment was defaulted to NOT checked.

    So something is up. Tonight I'll try the directions for my Mac.

  9. 7 Posted by Pirogue on 29 Apr, 2019 03:21 PM

    Pirogue's Avatar

    I had this problem and found out that it is meant to take your last choice and make it the default choice going forward but this doesn't always happen because it won't make the change if you have multiple instances of Daily Kos open at the same time. This may not be your problem but it is worth a try if you think it may have been the reason. Just close all instances of Daily Kos that are logged in to the site (I would include any on other media like phones and all browsers on a single computer that may have an instance open.)
    Hope this helps you, and if not perhaps someone else who is searching for a solution. It worked for me.

  10. Support Staff 8 Posted by Daily Kos Staff on 29 Apr, 2019 04:42 PM

    Daily Kos Staff's Avatar

    What a great point to raise, Pirogue. Quite right! Thank you for raising that as a possibility, too.

  11. 9 Posted by Franks Human on 29 Apr, 2019 04:59 PM

    Franks Human's Avatar

    JUST FYI for Help Desk: Pirogue's situation does not describe my situation.

    In a diary (about the comments changing) I left a comment and peregrine kate wrote this there to me: "I have a question for you: are you sure that your email of record for the site is current? That is one possible explanation for the problem we should rule out. Thank you."

    My email has not changed. I do not know how to check this to see if something changed so that my email is no longer the email of record for the site. How do I check that out for you?

  12. 10 Posted by Franks Human on 29 Apr, 2019 07:18 PM

    Franks Human's Avatar

    (Update: Peregrine Kate's message, I think, was to someone who had replied to me. So I don't think she meant that for me.)

    https://www.dailykos.com/comments/1853349/73698458
    (comment thread)

  13. Support Staff 11 Posted by Daily Kos Staff on 30 Apr, 2019 04:17 AM

    Daily Kos Staff's Avatar

    Thanks for raising that possibility, regarding the email of record. Without violating any confidentiality, I can state that is not an issue in your case, Franks Human.

    Unfortunately it is possible to have a number of different scenarios. You might have had only one tab open at a time, while someone else might have had multiple, as Pirogue is suggesting. In the case of multiple tabs, it is indeed difficult to sort out which one had the "latest" state recorded, so there is a potential source of confusion there for the cookie. That said, it also may well be the case that the cookie is NOT reverting to the default "on" setting. So, we'll do our best to scope out the various combinations and pursue a solution.

    Thanks again for your patience as we strive to fix this annoying glitch.

  14. Support Staff 12 Posted by Daily Kos Staff on 02 May, 2019 08:21 PM

    Daily Kos Staff's Avatar

    All right, I'm back with more answers, and I hope better ones.

    My apologies for giving you wrong information originally. This particular setting is tracked on the SERVERS not on the browsers, so it is not set via a cookie. (That's why it is not browser-specific.) That also means that you can't produce any change in behavior or reset to a default state by clearing your cookies. Sorry for leading you down that path.

    However, it IS possible that some of the data that your browser stores relative to our site has become outdated and/or stuck, in effect. So it would be a good idea for you to clear your local storage (not identical to your cache, which is typically a more short-term reservoir).

    One more thing to note after you clear it: that process will NOT reset your email-alert preference to the default state, which you as a user cannot regain. But it will potentially permit the latest preference to be tracked properly, so that the next time you choose the "email-alert = ON" option it is much more likely to stick.

    Now, it is only fair to note also that it's possible that we DO have a bug, too (or even instead). But this sort of troubleshooting to eliminate the individual, user case is helpful for us to narrow down the possibilities. Plus, if this remedy does suffice for you, it's a lot quicker of a fix than waiting for the ticket to make its way through the queue.

    Thanks again. Sorry again for my earlier misinformation.

  15. 13 Posted by Franks Human on 02 May, 2019 09:39 PM

    Franks Human's Avatar

    So, something apparently happened to change this suddenly on the servers related both to my home computer and my computer at work? (And no other sites have been affected in any way.) I may not understand where these servers are or how they could both be simultaneously impacted. I thought I understood servers prior to your message, and now I'm confused since this was my laptop at home and a work computer.

    It appears that I'll have to go into Firefox and clear my local storage, but when I looked just now there were five sites listed and nothing about Daily Kos there. From your descriptions I'm not clear on how to clear local storage, but it sounds as though I have to clear all my history again. (This keeps happening related to Daily Kos bugs in comments, and this makes me have to reset all my settings, including accessibility settings, over and over again.)

    And then you write that this will not reset my email-alert preference (and that "you as a user cannot regain.") That's all I'm doing this for, to regain that email-alert preference that had consistently been there until I opened this ticket.

    I understand the concept of something being stuck in a server until we clear it, but it sounds like after doing all this clearing and resetting my other sites I may end up back where I am right now: Having to check the box each time?

    So my question: Are you saying I need to clear all my local storage on each computer and then hopefully as I check the box again it will eventually catch on and reset? Or do I need to try to find Daily Kos related storage within my local storage and only clear that?

    (Truthfully, I don't want to clear my local storage but I'm willing to try a few more times to get this right. It's annoying to have to click that box each time, but doing all this is also annoying since it impacts all the other sites, which are working the same, so I'm conflicted. Right now, I'm just trying to be sure I clearly understand your message and remedy. I believe you that it's the servers, but that seems so bizarre that these two disparate servers suddenly experienced the same problem/change April 23 sometime after midnight that only impacted this one thing on one site.)

  16. Support Staff 14 Posted by Daily Kos Staff on 02 May, 2019 09:58 PM

    Daily Kos Staff's Avatar

    OK, looks like I was not clear. Sorry, these technical aspects often require a lot of detail and precision, and I am sure I have room for improvement.

    No, it's OUR site servers that store this information about users' preferences. Not the network hosts through which you're accessing the internet.

    And probably I gave too much information when I said you can't go back to your original setting. That does not mean it's impossible to get your preference to stick, as you note later. The setting you prefer should indeed be logged and served to you, once the local storage block is resolved.

    I think it's unlikely that you can find local storage on your browser that's labeled only for Daily Kos, but you can try.

    And you are quite right that it's odd that you would have experienced the same kind of local issue with storage in two different machines. It may well wind up that we track it back to a bug in our code in the end. But it's also true that there is more than one way to confound what we think we should see in terms of the last change made, so I do appreciate your willingness to eliminate this as a possibility for the hiccup as well.

    Thanks for your continued persistence with working through this problem. I'm also seeking to replicate the issue, and the details you've provided so far are helpful in that process.

  17. 15 Posted by Franks Human on 02 May, 2019 10:04 PM

    Franks Human's Avatar

    Okay, that makes sense now re: servers. So you're saying my local storage needs to be cleared so that (in effect) we give the setting on YOUR servers a chance to reset?

    (That confusion about servers shook me to the core! Everything I know is wrong again! :) )

    I may have to have my work IT person do this here. for work/Firefox. I looked up clear local storage on Firefox, but when I started to try to do it it seems unclear. I'll look up Safari and try to do this later, or over the weekend. Thank you.

  18. Support Staff 16 Posted by Daily Kos Staff on 06 May, 2019 08:43 PM

    Daily Kos Staff's Avatar

    Yes, thank you. I think that's a good restating of what I was trying to convey. Thanks for your patience with the process. These technical tools are great when they actually do what we want them to do.
    We're not entirely sure we have an answer to propose but these exchanges help us narrow down the possibilities. Appreciate your engagement here.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac