comment bug update

Glen The Plumber's Avatar

Glen The Plumber

27 Mar, 2019 02:11 PM

This comment was split from the discussion: Cannot post a comment

@elfling.

I will try to do this.

should I wait until the problem reoccurs..?? I cleared my cookies and currently it all works. but no doubt will happen again.

  1. Support Staff 1 Posted by Daily Kos Staff on 27 Mar, 2019 02:13 PM

    Daily Kos Staff's Avatar

    Hi Glen.
    Thanks for the report. I've split off your reply because there are a lot of people on the other thread who get notifications of any activity over there, and while your initial comment and elfling's update are helpful for the others, this follow-up might not be as much.
    Yes, we'll need to see the HAR file from when/if you see it again. The idea is that if you clear your cache (not so much your cookies) the browser will then not have a conflict with the new data it retrieves. Thanks for giving it a try. The HAR file is key to diagnosis and remedy.
    Did you also close and reopen your browser after you cleared your cache? Apparently that might be an important step too.
    Oh, and are you on mobile or desktop?

  2. 2 Posted by Glen The Plumbe... on 27 Mar, 2019 03:30 PM

    Glen The Plumber's Avatar

    howdy,

    mojave 10.14.3 on mac book pro

    safari 12.0.3 (14606.4.5)

    safari is stock the way it comes...nothing added.

    currently ok. previously cleared 'cookies, cache, databases, local storage'

    not sure if I shutdown safari and reopened. have done that now.

    typically takes about 24 hrs after clearing cookies etc before having the problem...will let you know and provide HAR if it happens again.

    thank you

  3. Support Staff 3 Posted by Daily Kos Staff on 27 Mar, 2019 05:40 PM

    Daily Kos Staff's Avatar

    You are the best, Glen, thanks. Fingers crossed. We found one more gap to fill in the remedy, so perhaps after that we'll be golden.

  4. 4 Posted by Glen The Plumbe... on 28 Mar, 2019 01:05 AM

    Glen The Plumber's Avatar

    the file is too big. I've emailed the HAR and screenshots to Neeta.

    hope this helps and thank you for all your efforts.

  5. Support Staff 5 Posted by Daily Kos Staff on 28 Mar, 2019 01:17 AM

    Daily Kos Staff's Avatar

    OK thank you.
    But uh oh, I take it this means you've had it happen again, later today? Not complaining about you, of course, just lamenting that we haven't fixed it all yet.

  6. 6 Posted by Glen The Plumbe... on 31 Mar, 2019 05:18 PM

    Glen The Plumber's Avatar

    update...

    after sending HAR file I cleared cookies, etc and have not had a problem since.

    will let you know if that changes...thank you for all you all do to keep this orange ship afloat.

  7. 7 Posted by Glen The Plumbe... on 04 Apr, 2019 12:56 AM

    Glen The Plumber's Avatar

    spoke too soon. yesterday while making a comment the tools did not render normally. I cleared cookies etc and it cleared up.

    now there are no tools.

  8. Support Staff 8 Posted by Daily Kos Staff on 04 Apr, 2019 03:52 PM

    Daily Kos Staff's Avatar

    Oh man! You seem to be our canary.
    You know, we did just do something that was supposed to have addressed this very issue (bad asset loading). Let me check into the status of that fix and get back to you.

  9. 9 Posted by madcitysailor on 04 Apr, 2019 04:35 PM

    madcitysailor's Avatar

    I have Mojave on a MacBookPro, and I cleared the cache. But I still cannot comment. Is there something else I was supposed to do? Full disclosure - I am pretty much a Luddite, so instructions must be for the complete idiot. Thanks.

  10. 10 Posted by lewschwenk on 04 Apr, 2019 10:50 PM

    lewschwenk's Avatar

    I have had the same problem on my iPhone, iPad, and Mac for about a week.
    After reading about clearing caches, etc., I found instructions to clear history and website data on my iPhone and iPad. Same for my Mac/Mojave.

    After clearing the history and website data on my iPhone, I then WAS able to open articles on DailyKos Recommended.
    I did the same for my iPad. The Mac instructions showed how to clear the Library Caches.
    Neither the iPad or my Mac could open DailyKos articles. The error messages continued, and I also got the 404 error, page not found.

    Then I went back to my iPhone, which HAD been able to open DK articles, and the error messages came up again. So that fix did not last long.

    I am far from being very techy, so now I'm at a loss what to do next.
    I seriously miss having access to DK emails and articles.

    I am wondering whether this problem, which seems to be affecting lots of people, might be a deliberate thing from some outside source.

    P.S. I also get the same error messages when I click on Action Network.org at the bottom of DK emails.

    Please let us all know if you learn more about this problem.

    Thanks.
    Lew

  11. Support Staff 11 Posted by Daily Kos Staff on 05 Apr, 2019 02:09 PM

    Daily Kos Staff's Avatar

    Sorry this has been a persistent issue for so many. We do not think it’s an externally-caused problem, or at least not in a malicious way.
    We did one more fix yesterday afternoon that we hope will be comprehensive. Clearing your browser cache for Safari one more time should help.
    It does seem that on the desktop platform Firefox & Chrome are less glitchy for people. But that’s not much help on mobiles, and in any case we don’t want to exclude Safari users.
    The Action Network issue is unrelated. That is pretty clearly a matter of overzealous security protections applied by your network or your email provider. We may have a general approach to apply but in the meantime we encourage users to permit link-forwarding and to accept links from sendgrid.net.
    Thanks for the updates. They are helpful albeit frustrating for you (& us) that they’re necessary at all.

  12. 12 Posted by lewschwenk on 05 Apr, 2019 04:05 PM

    lewschwenk's Avatar

    As of this morning, I still cannot open DK articles on either my iPhone or Macbook Pro. On my Mac, it is Firefox that is showing the warning. They offer an "Advanced" tab, which I clicked and made an "exception" for your site. Then when I tried to open an article, it went right to Error 404, Page Not Found.

    I do not know how to permit link-forwarding and to accept links from sendgrid.net.
    I suppose I could make an appointment with the Genius Bar at the Apple Store, but that's a lot of work and will take several days to get an appointment. Any further instruction you can provide would be appreciated. I hope this gets worked out for all.

    Thanks.
    Lew

  13. 13 Posted by lewschwenk on 05 Apr, 2019 07:49 PM

    lewschwenk's Avatar

    I went out for lunch and I WAS able to open DK articles on my iPhone using cellular service only. When I got home and hooked up to my home wifi, I could no longer open the articles.

    So it must have something to do with wifi. Unfortunately, I cannot run my iPad or Mac without wifi.

    Hope this helps.

    Lew

  14. 14 Posted by lewschwenk on 06 Apr, 2019 05:30 PM

    lewschwenk's Avatar

    Hey, this morning (Saturday) I was able to open Daily Kos articles even while using wifi. Looks like you fixed the problem.

    Thanks.

    Lew

  15. 15 Posted by Glen The Plumbe... on 08 Apr, 2019 12:55 AM

    Glen The Plumber's Avatar

    went for 3 or 4 days with no problems. today it is back. same as original problem...can't comment until I clear cookies, etc...

    :7(

  16. 16 Posted by Glen The Plumbe... on 09 Apr, 2019 02:50 PM

    Glen The Plumber's Avatar

    now it has happened twice in the last 12 hours or so. do you want a HAR if it happens again?

  17. Support Staff 17 Posted by Daily Kos Staff on 11 Apr, 2019 08:05 PM

    Daily Kos Staff's Avatar

    Hi, and apologies all around that this is dragging on so long.

    I'm going to post our newest edition of a reply, since this information will undoubtedly be shared beyond this Help Desk thread (which is of course fine).

    It has indeed been a chronic problem for our users, particularly those who use Safari on a desktop or mobile platform. Whether you are not seeing a comment box at all, or seeing something that looks like a whole array of icons not displayed in a useful form, the underlying issue is the same: the editor box is not fully loading.

    Our developers have identified the source of the problem, but so far our efforts to devise a permanent and comprehensive remedy have not done the trick. It's arising for other websites, too, and unfortunately at the moment we're forced to create our own workaround for it. The developers are still working on such a fix.

    Meanwhile, we have some workarounds to suggest.

    First, it will help if you clear your browser cache frequently for Daily Kos-related data AND then restart your browser immediately afterwards. It is NOT necessary or useful to clear cookies, which may make this process slightly less onerous. Instructions for clearing a browser cache, either on a desktop or a mobile browser, are available in many locations online.

    Second, it is also a good strategy to use a private window on Safari when you visit Daily Kos. Doing so prevents the kind of data upload from our server to your browser that elicits the misfire when you seek to comment or to post a story.

    Third (which for many users could be an unwelcome or inadequate solution), you may prefer to use a different browser altogether. But there's an important detail to keep in mind. All browsers available on iOS (that is, iPhones and iPads) also must use some core features of Safari. Thus, installing Firefox or Chrome on a mobile device might not fully address the problem for you. The other two workarounds, however, will suffice.

    We hope that this is helpful for you and other site users in the short term, as we pursue a better solution. We greatly appreciate your patience, and we thank you for your support of the mission of the site.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac