I can neither post comments nor activate the image library

Paul C's Avatar

Paul C

22 Mar, 2019 10:39 PM

Ok, in addition to not being able to open the image library, now I cannot post comments. So things are getting worse rather than better.

  1. 1 Posted by rkief on 22 Mar, 2019 10:58 PM

    rkief's Avatar

    Last week, I made an inappropriate comment, for which I was cut off for a few days - after which I seemed to be reinstated; today, I can no longer comment, but see no notice to that affect. So what's going on?

  2. 2 Posted by irishgurl on 23 Mar, 2019 12:26 AM

    irishgurl's Avatar

    I can’t either. I think they were saying it has to do with safari users(iPad here). Having your OS up to date( mine is) and only having a single window open ( did that also. I can type here, not in the comments section since this afternoon.

    Anyone else. I’ve signed in and out of my account. Shut my iPad down. Turned it back on and yelled at it some.

    So tell me, did I piss someone off accidentally and no one told me. If not, please help me also

  3. 3 Posted by irishgurl on 23 Mar, 2019 12:36 AM

    irishgurl's Avatar

    Lots of people can’t. I can’t either. Something to do with Safari?

  4. 4 Posted by Slouching (unve... on 23 Mar, 2019 12:39 AM

    Slouching's Avatar

    I don’t think I breached the community standards and can find no evidence that anyone else does but I can’t post comments.

  5. 5 Posted by Slouching (unve... on 23 Mar, 2019 12:41 AM

    Slouching's Avatar

    I can’t post comments.

  6. 6 Posted by Albanius on 23 Mar, 2019 01:06 AM

    Albanius's Avatar

    I have been unable to post comments since yesterday.

  7. Support Staff 7 Posted by Moderator1 on 23 Mar, 2019 11:19 AM

    Moderator1's Avatar

    Hello, and thanks for raising the alert here. As you’ll see, there is a LONG reply to come.

    This particular problem, from what we've seen, has occurred for a subset of Safari users. We've not yet been able to identify the underlying source of the problem.

    A step we took for other reasons, but which we hoped would address the problem, turned out not to have the desired side-effect.

    First, are you using the most recent version of Safari? (On Mac, it's 12.0.3, while on iOS it is 12.0.) Many users have their setup such that the browser updates are installed automatically, but if for some reason you're out of sync, you should take a moment to update yours.

    And, indeed, it is generally advisable to keep your operating system up to date. So if you've not yet moved to MacOS Mojave, it's a good idea to do so as soon as you can. Many people have already said that this alone has resolved the problem for them.

    IF you take these steps and STILL have a problem, then please read on.

    If need be, we have some workarounds to suggest above and beyond the browser and operating system update. These reinforce, in part, the suggestions that have been made here and in other Help Desk threads and on the live site. Thanks for the crowd-sourcing!

    Try to access the site while you are on a private window in Safari. That eliminates one major source of difficulty (the site cache and cookies) though you will have to login again.

    Part of the difficulty is that we have not been able to replicate the issue here. If someone who is experiencing the problem can capture some browser information for us, that would be really helpful. Here is a site that provides a step-by-step explanation about how to do it: https://support.cloudflare.com/hc/en-us/articles/203118044-How-do-I Please don’t worry about it if it’s not possible for you to do it, but if you want to give it a go we’d be grateful. You can open a new ticket for us and attach the file there.

    Any or all of these will probably work for you. One more time: do please start with the browser and operating system update.

    Thanks much for your understanding, your patience, your suggestions, and your support of the mission of the site.

    There are a number of threads here on this issue, so I am going to close as many of them as I can now so as to minimize the alerts that you will all get.

  8. Moderator1 closed this discussion on 23 Mar, 2019 11:19 AM.

  9. Ellyn O re-opened this discussion on 23 Mar, 2019 04:30 PM

  10. 8 Posted by Ellyn O (unveri... on 23 Mar, 2019 04:30 PM

    Ellyn O's Avatar

    This is a new IPad. I have the latest operating system.

  11. 9 Posted by SFRick (unverif... on 23 Mar, 2019 08:40 PM

    SFRick's Avatar

    FWIW, I can't comment, either.

  12. 10 Posted by irishgurl on 25 Mar, 2019 02:42 PM

    irishgurl's Avatar

    I found this helpful if you are on an iPad. Latest updates of course. Go into settings, then safari, then advanced, then website data. Find daily Kos. Hit edit and delete Kos. Go back to the Kos website, sign back in and you should be able to comment. It removes the cookies from Kos only, but allows cookies to remain for all other websites.

  13. Support Staff 11 Posted by Daily Kos Staff on 25 Mar, 2019 04:13 PM

    Daily Kos Staff's Avatar

    Thanks, irishgurl. Good step-by-step there, and that process does help. Problem is that generally people have to repeat the cookie-deletion each time they visit the site.

    Our developers do have a good set of data to review about the cause of the glitch, and they're working on a full diagnosis and fix.

    For those of you with more specific inquiries about the status of your account: I'll split off your query to a separate thread. Y'all don't need to see every single reply. ;)

  14. Daily Kos Staff closed this discussion on 25 Mar, 2019 04:13 PM.

  15. rkief re-opened this discussion on 28 Mar, 2019 06:33 PM

  16. 12 Posted by rkief on 28 Mar, 2019 06:33 PM

    rkief's Avatar

    I had the Safari update installed, and apparently it works. Thanks for the tip.

  17. 13 Posted by Paul C on 28 Mar, 2019 08:38 PM

    Paul C's Avatar

    To provide further debug info for the staff, I am still having the same problem even though I reloaded/updated my entire computer, including OS and all apps, from scratch.

    However, I am not using Safari. I am on a Gentoo Linux machine with GTK+ based gnome desktop environment on X11 windows and my browser is Web 3.30.2 which is based upon WebKitGTK+ 2.22.6.

  18. 14 Posted by Paul C on 29 Mar, 2019 03:21 AM

    Paul C's Avatar

    I also tried deleting the dailykos cookies before logging in but that made no difference.

  19. 15 Posted by Paul C on 29 Mar, 2019 05:21 AM

    Paul C's Avatar

    I followed the Cloudflare instructions for obtaining a HAR on Firefox but there were issues. I had to use Ctrl+Shift+i to get the tool to open. Right away it said there were errors. I was in the comments section of a diary so I am wondering if the comment boxes at the top and bottom of that section for me to comment generated those errors as they were being rendered since they are not rendered normally, having whited out borders and being unresponsive to clicking inside them - same thing when I click on a "respond" and get a non-functioning box.

    The 'export' button was nonresponsive. The best I could do was copy the 'console' error display contents into the attached file. Again, I don't know if this is useful or even what it means since this is all outside my range of expertise.

  20. 16 Posted by Raymond Cliffor... on 29 Mar, 2019 05:09 PM

    Raymond Clifford 's Avatar

    I use Safari for Daily Kos and I just noticed the letters won’t work!

  21. 17 Posted by Michael Gutierr... on 29 Mar, 2019 08:24 PM

    Michael Gutierrez's Avatar

    Firefox and Chrome on PC cannot comment

  22. 18 Posted by Paul C on 30 Mar, 2019 07:33 AM

    Paul C's Avatar

    Ok, I can post comments now! Clearing cookies did nothing.

    This time I selected from my "Web" (gnome desktop) browser:
        'Preferences" -> "Stored Data" -> "Manage Personal Data"

    and went through and cleared non-critical site data that the web browser stores on my online activities. These are the categories of data that I manually went through and selectively cleared:
      HTTP disk cache
      Local Storage Data
      Offline web app cache
      IndexedDB databases
      WebSQL databases

    So it is not the cookies but the cached data that is clashing with whatever changes have been made on the DKos website. I logged out after finding I could comment and logged back in without making any further changes and I still could comment. So far it appears to be a permanent fix. If I find out differently I will post again.

    I am guessing that the reason clearing cookies works for Safari on a per session basis has something to do with how Safari accesses cached site data. It must look for a cookie and if it doesn't find it then it assumes there is no cached data. If so, my browser must look for them separately because clearing cookies had no effect but clearing the cache worked. So when Safari users revisit DKos it puts the cookies back and that would cause the cache to be called the next visit and cause the problem again.

    However, I am not trained at web programming so this is all speculation on my part. All I know for sure is that I cleared the relevant cache data and now it appears I am back in business.

    Note - the reason my cache data was preserved even though I reloaded my OS is that I left my personal home directory partition intact, reloaded the OS and apps, then simply remounted my home partition. This might prove that the problem has to be in the personal cache, not a virus or something to do with my browser or the DKos site beyond the fact that changes were made that appear to clash with prior cache data.

  23. 19 Posted by Olds88 on 30 Mar, 2019 04:46 PM

    Olds88's Avatar

    Chrome on iPhone stopped working last week. If I hit reply, I got a blank box into which I could not type. Also, the format menu bar does not appear.
    I switched to Firefox. That worked fine until yesterday when I updated the app. Now it acts the same as Chrome.
    I have switched to a third browser called “Browser”. That works at the moment.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac