Cannot Post Diary

tiredntexas's Avatar

tiredntexas

21 Mar, 2019 02:26 PM

I receive the following message when I try to post a diary:

Bad Request! (400)

Your browser sent a request that this server could not understand.

  1. Support Staff 1 Posted by Daily Kos Staff on 21 Mar, 2019 02:45 PM

    Daily Kos Staff's Avatar

    Thanks for the alert.
    We'll dig into the problem, which has been reported by a number of users now.
    Meanwhile, there are a couple of workarounds you can try. First, please see if the process succeeds while you are logged in while using a private or incognito window. It's possible that there is a new conflict between your setup and our site. You can also see if you can publish the post when you are from your queue, NOT from the story editor page. (You can do that if you look at your Drafts, from your personal page or from your profile pull-down.) If neither of these work, please let us know.
    Also, if would be helpful for you -- and for everyone else who may reply to this thread -- to let us know what your set up is (operating system and browser).

  2. 2 Posted by tiredntexas on 21 Mar, 2019 03:05 PM

    tiredntexas's Avatar

    My operating system is macOS Mojave...browser is Chrome

  3. Support Staff 3 Posted by Daily Kos Staff on 21 Mar, 2019 03:45 PM

    Daily Kos Staff's Avatar

    Great, thanks.
    Did you try either one of those workarounds, and were they successful?

  4. 4 Posted by tiredntexas on 21 Mar, 2019 06:51 PM

    tiredntexas's Avatar

    I tried and neither were successful.

  5. 5 Posted by tiredntexas on 21 Mar, 2019 06:52 PM

    tiredntexas's Avatar

    Yes, but neither were successful.

  6. 6 Posted by tiredntexas on 21 Mar, 2019 06:55 PM

    tiredntexas's Avatar

    I posted a diary yesterday. Is there a timeout/limit on the number of diaries that can be posted in a given period of time?

  7. Support Staff 7 Posted by Daily Kos Staff on 21 Mar, 2019 06:59 PM

    Daily Kos Staff's Avatar

    Ah, that's helpful information.
    There is, but it's a pretty generous one, definitely larger than two per day.
    Would you mind trying to clear your cookies for dailykos.com and attempting to publish it again? Make sure that you have at least one tag.
    Thanks.

  8. 8 Posted by tiredntexas on 21 Mar, 2019 08:29 PM

    tiredntexas's Avatar

    I cleared cookies, tried to post from other devices as well as from both Chrome and Safari and still get the same error message. I even deleted the diary and tried to post again. Same error message.

  9. 9 Posted by tiredntexas on 21 Mar, 2019 10:53 PM

    tiredntexas's Avatar

    Hello again,

    Will there be a resolution to my issue? I've never had this problem in 12 years and the Help Desk comments are taking me in circles. At the end of the day, the issue persists with no other feedback from the Help Desk. I will be canceling my subscription if I cannot get a timely resolution.

  10. Support Staff 10 Posted by Daily Kos Staff on 02 Apr, 2019 03:33 PM

    Daily Kos Staff's Avatar

    Hello, and apologies for the lag in replying constructively to your issue. The troubleshooting that you've done, including the attempt to post from other browsers, is helpful.

    Also, have you been able to post comments in this time? It's possible that the problem that you've been having is related to another one that cropped up at about the same moment.

    The other major troubleshooting step that you could take for us would be to capture a HAR file. Without being able to replicate the problem ourselves, we need a track of the code that shows exactly where the block is. Here is an explanation of how to get that record. https://support.cloudflare.com/hc/en-us/articles/203118044-How-do-I...

    The HD does permit sending attachments, though it is possible you will have to make a zip file of the HAR results to avoid the size limitation.

    It is indeed frustrating to encounter this kind of obstacle, and you are not alone in having this difficulty. As soon as we can track down what's happening, we'll be able to start diagnosing and fixing it.

  11. 11 Posted by tiredntexas on 02 Apr, 2019 04:05 PM

    tiredntexas's Avatar

    Thanks for getting back to me. Yes, I am able to post comments. I believe I was able to capture an HAR file for my issue (see attached).

  12. Support Staff 12 Posted by Daily Kos Staff on 02 Apr, 2019 05:39 PM

    Daily Kos Staff's Avatar

    Thank you so much for getting this documentation! I will pass it along to the devs, and perhaps they will have more questions to pass along to you through me.

  13. Support Staff 13 Posted by Daily Kos Staff on 02 Apr, 2019 07:07 PM

    Daily Kos Staff's Avatar

    I do have one more suggestion for you to try on your end first, if you don't mind.

    You've said you've cleared your browser cache, but it also might help if you clear your DNS cache, which is not the same thing. Somehow, the connection between your computer and our servers is not succeeding, and clearing the browser cache does not address that issue.

    Thanks for your willingness to check into this possible remedy, too. Sorry it's been such a difficult stretch.

    PS--I asked this earlier, but wanted to double-check: A story must have at least one TAG to be published. Lacking a tag will also cause a 400-related error message without giving any more information.

  14. 14 Posted by tiredntexas on 02 Apr, 2019 07:35 PM

    tiredntexas's Avatar

    I included a tag and was able to post my diary. Thanks again for getting back with me. I sincerely appreciate it and will be renewing my subscription.

  15. Support Staff 15 Posted by Daily Kos Staff on 02 Apr, 2019 07:38 PM

    Daily Kos Staff's Avatar

    OK! Great, thanks.
    Glad to have you completely able to access the site again.

  16. Daily Kos Staff closed this discussion on 02 Apr, 2019 07:38 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac