Firefox misformats some charaters such as curly single and double quote

Jim8475's Avatar

Jim8475

16 Apr, 2018 01:42 AM

On Twitter text quotes show up malformatted. For instance, the word can’t shows up as can’t and “memos” shows up as “memos†The problem seems to relate to the use of “curly” single and double quote marks. This is not a problem with Chrome or MS Edge.

I've tried changing the fonts on Firefox to avail, including disabling "Allow pages to choose their own fonts, instead of your selections above".

This makes reading rather difficult sometimes especially with Trump's enclosing words such as “memos” in https://www.dailykos.com/stories/2018/4/15/1757235/-Portrait-of-a-M...

Do other Firefox users have this problem? Is there a simple fix? If not, would it be possible to change “curly” quote marks to "straight" marks? This would help considerably.

Thank you -Jim

  1. 1 Posted by Jim8475 on 16 Apr, 2018 02:44 AM

    Jim8475's Avatar

    Addendum: Other non-straight quotes such as “Myrtle” on the link below are in a different font and show up correctly.
    https://www.dailykos.com/stories/2018/4/14/1680540/-Still-More-Ques...

  2. 2 Posted by siab on 16 Apr, 2018 05:13 AM

    siab's Avatar

    Usually this occurs when the original tweet has been deleted, or when there's a problem with the page loading. Generally, when it's the second, reloading the page will correct it; for the first, I have no help to offer. When there's a slow load I sometimes watch both the garble and the actual tweets load in succession.

    You may get more of an answer when the weekend is over. In the meantime, I offer this as one user to another.

  3. 3 Posted by Jim8475 on 16 Apr, 2018 10:17 AM

    Jim8475's Avatar

    Thanks for your reply, siab. The tweet has not been deleted and reloading the page (multiple times) doesn't fix the problem.

  4. 4 Posted by T100R on 16 Apr, 2018 02:58 PM

    T100R's Avatar

    This can happen if you are running the Ghostery extension. It may happen with other blockers as well. It is possible to tweak the Ghostery settings to allow tweets to be fully rendered.

  5. 5 Posted by Jim8475 on 16 Apr, 2018 08:07 PM

    Jim8475's Avatar

    (edited) The extensions that I have are:

    • minerBlock
    • YesScript2
    • an RPN calcuator.

    The plugins are the default:

    • Widevine Content Decryption Module provided by Google 1.4.8.1008
    • Shockwave Flash 29.0 r0
    • OpenH264 Video Codec provided by Cisco Systems, Inc.

    I disabled all extensions and plugins. Also cleared cache, cookies, and site data. Still does the same thing.

    However, when I logged in the same computer under a different account, the formatting is good. Any suggestions? Reinstall Firefox?

  6. 6 Posted by aoeu on 17 Apr, 2018 10:33 PM

    aoeu's Avatar

    I have seen of this behavior, too.

    aoeu

  7. 7 Posted by Eyesbright on 18 Apr, 2018 01:13 AM

    Eyesbright's Avatar

    The hard-to-read malformation of virtually all tweets that are posted here is so common that I expect it. I've also seen the same thing at several other sites. I doubt sincerely that extensions/plug-ins have anything to do with it (I don't have any).

  8. 8 Posted by T100R on 18 Apr, 2018 05:48 PM

    T100R's Avatar

    OK, try this.

    1. Open Firefox Preferences
    2. Select "Privacy & Security" on the upper left.
    3. Scroll down to Tracking Protection, and select "Never"

    Close preferences, clear your cache, then see if that fixes it. If it does, and if you want to continue Tracker Protection (recommended), you'll have to figure out how to set up an exception for Twitter. (I didn't pursue it that far).

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac