Can't Embed Tweets Or Properly See Embedded Tweets

oldhippiedude's Avatar


13 Jan, 2018 03:11 AM

As the title says. This just began occurring. Embedded tweets appear as pure text without the proper Twitter formatting. The only update I did today was to one of my browsers (Brave), but this issue has occurred in Firefox, Chrome, Chromium, and Iridium as well as Brave. I use Ghostery, Privacy Badger, Adguard, and UBlock Origin, but there have been no recent changes to the settings on any of these.

Any help or suggestions would be appreciated. I have enclosed a screenshot illustrating the problem.

  1. 1 Posted by nomandates on 13 Jan, 2018 02:47 PM

    nomandates's Avatar

    Same problems here. I use Chrome, and the same thing has been happening to me when trying to embed tweets containing pics in comments. First time I encountered this problem was Wednesday evening when I could no longer see the tweet pics in any diary or comment.

  2. 2 Posted by Besame on 13 Jan, 2018 10:52 PM

    Besame's Avatar

    Works ok for me in stories and comments using OS High Sierra and Chrome.

  3. 3 Posted by Otteray Scribe on 14 Jan, 2018 08:58 AM

    Otteray Scribe's Avatar

    When you pull up the embed screen on twitter, did you make sure the "Embed media" box is checked? That adds any images or GIFs attached to the tweet.

  4. 4 Posted by oldhippiedude on 14 Jan, 2018 04:11 PM

    oldhippiedude's Avatar

    OK, upon further research, it appears that I cannot see properly formatted embedded tweets on any site. The problem is obviously not with DKos but with my setup.

    Checking around the Web I have seen other posts from people with similar issues, and they seem to occur for some people and not for others, much like with nomandates and Besame above. Maybe Twitter is the problem?

    I've been embedding tweets for well over a year and have never seen this, but clearly I have some work to do. Thanks to everyone who offered feedback.

  5. 5 Posted by oldhippiedude on 15 Jan, 2018 06:03 AM

    oldhippiedude's Avatar

    I found the fix for this. Probably as a result of some change at Twitter, one must now permit the placing of third-party cookies in order to properly see embedded tweets. I've done this with a browser that I will henceforth use solely for DKos and everything's good now.

    Special thanks to slab for a suggestion which led me to check that particular browser setting. I'm going to go ahead and close this discussion now.

  6. oldhippiedude closed this discussion on 15 Jan, 2018 06:04 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac