Image Library troubles

Besame's Avatar

Besame

05 Jun, 2019 04:58 PM

Hang with me as I try to explain what's happening with using IL in comments - MacBook Pro Mojave Chrome (all latest versions).
 - with screen view set at 100% while I'm writing a comment and open the IL I get various oddies - most persistent is the entire IL dialogue box is not visible or useable so I can add a new photo to the IL but not add any data (attribution, tag etc). Most often (but not always - it changes rapidly as I stare at the screen w/o me doing anything) I can't post the image even after it loads because the CHOOSE button isn't visible. Except now and then the IL box suddenly goes into "normal mode" instantly and I could click on the CHOOSE button if I were fast enough (but I never am).

- Usually, to click on CHOOSE, I need to zoom out to 75% view and then I can see and click on the CHOOSE button but I still can't add the attribution, use permissions etc because that right hand panel isn't accessible.

- The IL works as normal when not in a comment.

Two screenshots attached (nope - will try to attach them one by one in replies because I got the 413 entity too large message when I tried to create this ticket with both attached and again with only one attached) - one at 100% and the other at 75%. I couldn't even take a screenshot showing the screen outside the IL dialogue box because the moment I clicked outside the box, the IL box vanished. So I had to click inside the dialogue box and do a selected screen shot of just the box. But this didn't happen at 100%.

  1. Support Staff 1 Posted by Daily Kos Staff on 05 Jun, 2019 09:54 PM

    Daily Kos Staff's Avatar

    Ah yes, I did get the images. Thank you for sending them.
    I'll continue to reply here since you have so much more detail included. At the moment, though, I'm seeing two different problems. (At least, I think they are different.) One is that the right sidebar doesn't consistently load for you to make any edits there. The other is related to scrolling.
    It is going to take a day or two to begin to address this problem, but in the meantime, do you have a workaround? Can you use click-and-drag, for example, to get the IL window to move? Or have you switched back to the old comments for now--and if so, does that make the IL behave properly?
    The sidebar not loading at all is definitely a more immediate concern, and I'll start to investigate.

  2. 2 Posted by Besame on 05 Jun, 2019 11:09 PM

    Besame's Avatar

    Thanks. I can zoom out to get the Choose button to work. I can upload an
    image for a comment and then after posting the comment leave comments and
    open the IL independently and add the data in the right panel. The IL works
    fine as long as it isn't associated with a comment although I've not tried
    to add an image to a story draft (will check that out and report back if
    it's a problem there, too). In the Daily Bucket where I was having IL
    troubles, I mentioned it in my comment and OceanDiver tried it with her
    iPad and everything worked as usual (fine) for her. So - something with
    Mojave and Chrome? I think (not 100% sure) her iPad uses Safari and may not
    be the newest iOS (because the iPad is too old to update?).

  3. Support Staff 3 Posted by Daily Kos Staff on 06 Jun, 2019 02:59 PM

    Daily Kos Staff's Avatar

    Ah I see. Good thinking.
    The variability of behavior depending on the OS/browser combination is an ongoing puzzle, challenge, and frustration.

  4. 4 Posted by Besame on 15 Jun, 2019 06:51 PM

    Besame's Avatar

    Update on this. Still an issue but not quite as bad. With my screen view at "Actual Size" (which is 100%) I can upload an image to the IL when I'm in a comment but the last few edit fields (Date Taken; Location) aren't visible.

  5. 5 Posted by Besame on 15 Jun, 2019 08:57 PM

    Besame's Avatar

    I was talking about this in the PWB Peeps diary today (Saturday) and someone mentioned the internal scroll bar in the right edge of each box within the IL popup. The scroll bar in the thumbnail box will allow scrolling thru the photos okay. But the scroll bar in the right panel only appears when the photo itself is big - smaller photos somehow do not generate a scroll bar and the data fields (location, uploader etc) are not accessible.

  6. Support Staff 6 Posted by Daily Kos Staff on 17 Jun, 2019 07:27 PM

    Daily Kos Staff's Avatar

    Thanks for providing additional detail. I'm sure it's annoying not to have full functionality when you were accustomed to having it before. I'll make note of these specifics.

  7. 7 Posted by Besame on 17 Jun, 2019 08:46 PM

    Besame's Avatar

    Fortunately, this doesn't rise to the level of minor annoyance for me (my
    measurement scale having altered dramatically ). I'm telling you so you
    have as much info as possible to ID the problem.

  8. Support Staff 8 Posted by Daily Kos Staff on 17 Jun, 2019 09:03 PM

    Daily Kos Staff's Avatar

    Oh, sigh. I am sorry that you have had occasion to make such a major recalibration. Indeed, in the scheme of things this sort of issue is barely a blip. But we'll still address it, all the same.

  9. Daily Kos Staff closed this discussion on 17 Jun, 2019 09:03 PM.

  10. Besame re-opened this discussion on 01 Sep, 2019 02:35 AM

  11. 9 Posted by Besame on 01 Sep, 2019 02:35 AM

    Besame's Avatar

    Reopening this discussion because of similar Image Library woes to those I already described above. I can upload an image and add the associated data and the CHOOSE button is visible.

    But, my work around for IL issues no longer works well because I cannot scroll thru MY images already uploaded into the IL whether I open the IL from the edit icon in a comment or from the menu under my name on the FP. That scroll bar on the right side of the left panel in the pop up box doesn't appear. Doesn't matter if I'm at 110% or 50% view. Sometimes (rarely) when I"m looking at DK images (not my own) the scroll bar flashes into view for an instant and then disappears. I always see it by accident moving my cursor just right, after I've already tried to trigger into appearing and nothing has happened. I'm never able to re-trigger its appearance though.

    This means that all my images but those that appear in the top of the IL box thumbnails immediately are lost to me unless I know some of the associated data and can search for them.

    Same OS etc as listed above, all updated and shiny.

    I know this won't get any attention over the holiday weekend and it isn't urgent. Been a problem for at least a few weeks and I finally decided to gripe. Thanks for your help.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac