Stuttering screen during scroll

Qveris's Avatar

Qveris

21 May, 2019 07:09 PM

In current Chrome/Windows 10, if the new comments code is active, the screen jumps quite violently when scrolling.

  1. Support Staff 1 Posted by Daily Kos Staff on 21 May, 2019 07:20 PM

    Daily Kos Staff's Avatar

    This is what we need to hear. (Sorry, though.)
    The ticket is PUBLIC and we will leave it open to collect more feedback from users. Thank you.

  2. Support Staff 2 Posted by Daily Kos Staff on 21 May, 2019 07:41 PM

    Daily Kos Staff's Avatar

    Qveris, and anyone else who has this issue: Please also let us know what you use to scroll: mouse, wheel, trackpad, scrollbar in browser window, etc. (plus your Operating System and browser info). The last time it happened, while we were beta-testing the new structure, we found a very particular scrolling setup & technique to be the cause of the problem.

    Also, it would be good to know if you have plug-ins, and if so the kind they are (ad blocker? third-party blocker? etc.).

    Please note: It is always possible to open a PRIVATE ticket here at Help Desk if you prefer to limit access to these details about your own system.

    Thanks for your help with troubleshooting.

  3. 3 Posted by renbear on 21 May, 2019 08:10 PM

    renbear's Avatar

    OS is Windows 10 Pro, browser is Chrome 74. Mouse is Logitech G600. Scrolling via scroll wheel, as I've described in the thread on the main site. Using the default Microsoft drivers for the mouse, no specialized software.
    Addons/extensions:
    Adblock Plus (<-- I've tried disabling this, no effect)
    Application Launcher for Drive (by Google)
    Chrome Remote Desktop
    Docs PDF/PowerPoint Viewer (by Google)
    Google Calendar
    Google Docs Offline
    Google Hangouts
    Google Keep Chrome Extension
    Kee - Password Manager
    RSS Subscription Extension (by Google)
    Save to Pocket
    Timeline Support

    And now, I'm going to go record that new video :-)

  4. 4 Posted by renbear on 21 May, 2019 08:24 PM

    renbear's Avatar
  5. Support Staff 5 Posted by Daily Kos Staff on 21 May, 2019 08:26 PM

    Daily Kos Staff's Avatar

    Excellent, renbear, and thanks on all counts.

  6. 6 Posted by Cali Scribe on 21 May, 2019 08:31 PM

    Cali Scribe's Avatar

    I just posted similar issue on the Help Desk -- I use a mouse wheel (wireless mouse) to scroll, and the only extensuon I have installed currently is the MTKA extension (Make Trump Kittens Again). :-)

  7. 7 Posted by Qveris on 21 May, 2019 08:58 PM

    Qveris's Avatar

    Maybe:

     [Intervention] Unable to preventDefault inside passive event listener due to target being treated as passive. See https://www.chromestatus.com/features/6662647093133312

    VisibleComments.js:176

  8. Support Staff 8 Posted by Daily Kos Staff on 21 May, 2019 09:11 PM

    Daily Kos Staff's Avatar

    Good point, and thank you.

  9. 9 Posted by Qveris on 22 May, 2019 11:39 PM

    Qveris's Avatar

    As of the time of this post, the stuttering has improved. Wheel scrolling now performs in Chrome as it did in Firefox yesterday.

    Which means wheel scrolling is not blatantly broken, but it is certainly not smooth. It is jumpy, it scrolls multiple lines at a time, apparently in some multiple of whatever setting is chosen in Windows 10 wheel scrolling preferences.

    Better, but I hope you can eventually manage a smooth scroll even within your ambitious scrolling code imperatives.

  10. 10 Posted by Qveris on 23 May, 2019 02:36 AM

    Qveris's Avatar

    Let me be clearer and more focused. Your scroll fix works, but it seems to disable smooth scrolling in Chrome.

    If I manually disable smooth scrolling in Chrome (Chrome//flags), wheel scrolling, with or without comments up, is equally "choppy", ie, multiple lines are scrolled per "click".

    If I enable smooth scrolling (which is currently Chrome's default), wheel scrolling is smoothed *unless* comments are up.

    Hope that helps.

  11. 11 Posted by jwinIL14 on 23 May, 2019 10:25 AM

    jwinIL14's Avatar

    Same issues, latest updates throughout
    64 bit quad core desktop
    Win 10 pro
    Chrome
    Microsoft scroll mouse
    Adblock Plus

    Thanks SO much for looking into this! Let me know if you need anymore info. to help.

  12. 12 Posted by VelvetElvis (un... on 23 May, 2019 04:42 PM

    VelvetElvis's Avatar

    I had the same problem as in the video above. It's now much better but not completely resolved. The scroll wheel now scrolls nearly half a page per click on the scroll wheel.

    Like a few others I've seen commenting on this, I'm using logitech peripherals (M570 trackball and K350 wireless keyboard) with the universal receiver. The SetPoint software is installed but disabled on startup. The browser extension is not installed. Logitech has their own GPU based smooth scrolling technology that's been causing this type of problem for years. I'm assuming it's the culprit in my case despite being disabled. Everything is now usable so I'm fine with it.

    https://community.logitech.com/s/question/0D531000050zxwkCAA/performance-mx-scroll-jumpingerraticinconsistent

    The problem has never been present using the same hardware and browser configuration under Linux.

    I can give full info on my setup if it would be helpful but you seem to have it mostly fixed.

  13. Support Staff 13 Posted by Daily Kos Staff on 23 May, 2019 05:08 PM

    Daily Kos Staff's Avatar

    Really great to have so much detailed information from y'all. Thank you.
    It appears there are a few aspects to tidy up, and we'll get to them as soon as we can.

  14. 14 Posted by aoeu on 24 May, 2019 12:19 AM

    aoeu's Avatar

    I posted details of my setup in the diary and would like to add that the behavior occurs when I scroll using the wheel on my MS Trackball Optical. The behavior is that the scroll interval is five lines per click of the wheel and it is a jump rather than a gentle scrolling action seen elsewhere on the web including the DailyKos help desk site.

    Edit to add
    I am also seeing the behavior in this thread:
    https://helpdesk.dailykos.com/discussions/new-lazy-comments-issues/...
    Whether they are related is above my pay grade
    Windows 10 Pro 1809
    Firefox
    adblock
    noscript
    netcraft
    form history control
    FVD

  15. 15 Posted by Creamy Goodness on 24 May, 2019 03:15 AM

    Creamy Goodness's Avatar

    On my system, the homepage scrolls fine but any post page has two issues with scrolling.

    The first issue is that the amount of trackpad input required to scroll is much, much higher than would ordinarily be expected. This seems different from what other people are reporting, but it's worth noting that it's easy to accidentally clear the threshold for nonlinear very fast scrolling resulting in something that feels like a jerk and difficult to control.

    The second issue is that scrolling is not smooth and stutters at a rate of several times per second, maybe 5-10 Hz. Some of these stutters move farther than others.

    My system:

    • 2012 MacBook Pro "Retina" 15
    • Mac OS Mojave 10.14.5
    • Firefox 66.0.5
    • Built-in trackpad

    While I ordinarily run with a few add-ons (Privacy Badger, uBlock Origin, HTTPS Everywhere), I disabled them for troubleshooting purposes.

  16. 16 Posted by Creamy Goodness on 24 May, 2019 04:29 PM

    Creamy Goodness's Avatar

    More information: the slowness of comments only manifests while logged in.

    WIth the exact same system but logged out, scrolling is completely fine -- responsive and smooth.

  17. 17 Posted by Creamy Goodness on 29 May, 2019 03:38 AM

    Creamy Goodness's Avatar

    Sometime on Saturday this problem suddenly seemed to get solved.

    Thanks for your efforts!

  18. Support Staff 18 Posted by Daily Kos Staff on 31 May, 2019 05:31 PM

    Daily Kos Staff's Avatar

    Thanks. Any change that you might have seen last week is likely to have come from us turning OFF the new comments for the time being, so that we could attend to another major glitch. But they will be back soon, and we'll still dig into a better remedy.

  19. Daily Kos Staff closed this discussion on 31 May, 2019 05:31 PM.

  20. Moderator1 re-opened this discussion on 31 May, 2019 05:59 PM

  21. Moderator1 closed this discussion on 31 May, 2019 05:59 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac