Error message when sending private message

ArcticStones's Avatar

ArcticStones

02 Aug, 2019 01:40 AM

Greetings! I just tried to send a message to one of the staff writers, Carolyn Fiddler. That gave me the following error message:

Can't call method "id" on an undefined value at /www/dk4-perl/current/lib/ScoopDK/Data/User.pm line 251.

What does this mean, and how should I deal with it?

Best regards,
ArcticStones

  1. 1 Posted by ArcticStones on 02 Aug, 2019 01:44 AM

    ArcticStones's Avatar

    I copied the message and tried resending. This time it was successful!
    But it might be helpful to know what went wrong the first time.

    Best regards,
    ArcticStones

  2. Support Staff 2 Posted by Moderator1 on 02 Aug, 2019 02:32 AM

    Moderator1's Avatar

    Hi

    We are aware of this intermittent glitch. As you discovered, trying again can sometimes work.

    Also, when the kosmail fails to send, sometimes hitting the Back button also works.

  3. Moderator1 closed this discussion on 02 Aug, 2019 02:32 AM.

  4. ArcticStones re-opened this discussion on 02 Aug, 2019 10:27 AM

  5. 3 Posted by ArcticStones on 02 Aug, 2019 10:27 AM

    ArcticStones's Avatar

    Thank you!

  6. Support Staff 4 Posted by Daily Kos Staff on 02 Aug, 2019 03:25 PM

    Daily Kos Staff's Avatar

    PS--Just so you know, it wasn't anything you did, nor can you prevent it. It's an issue arising between the two main platforms of the site, and only replacing the old-style pages will eliminate it. Fortunately, we're getting closer to that moment all the time, but unfortunately we still don't have a definite date for the change.
    It happens often enough that it can be worthwhile for users to save a copy of a long message elsewhere before trying to send it, in case the transmission is lost completely.

  7. Daily Kos Staff closed this discussion on 02 Aug, 2019 03:25 PM.

  8. ArcticStones re-opened this discussion on 02 Aug, 2019 03:32 PM

  9. 5 Posted by ArcticStones on 02 Aug, 2019 03:32 PM

    ArcticStones's Avatar

    Thanks for this more detailed explanation. I really appreciate it!
    Fortunately I was able to retrieve my message by hitting Back.

    If your development staff controls the contents of the error message,
    perhaps you can add the suggestion:

    ³You can probably retrieve your message by hitting Back.²

    Best regards,
    ArcticStones

  10. Moderator1 closed this discussion on 05 Oct, 2019 12:31 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac