Embed and rec problems

Otteray Scribe's Avatar

Otteray Scribe

27 Jun, 2013 02:07 PM

I tried to embed videos and nothing happens. Last night was the first time this has happened to me. It did not show up in the preview, but I thought it was being quirky, so posted anyway. Post looks exactly like the preview did. I tried again several times this morning in other diaries at random, using different videos, and get same result in preview every time. Blank space where video should be. Here is the comment from last night. Also, shortfinals said he was trying to rec my comments and the recs would not "take." He was able to rec other comments besides mine, and other people seemed to be able to give me some recs without difficulty. Here is link to the video-less comment:

http://www.dailykos.com/comments/1218916/50564304#c4

Thanks,
OS

  1. 1 Posted by JayRaye on 27 Jun, 2013 02:14 PM

    JayRaye's Avatar

    Me to, videos will not embed, blank space where vid should be.

  2. 2 Posted by poligirl on 27 Jun, 2013 04:03 PM

    poligirl's Avatar

    mine either, not using the iframe or the old code... videos will not post.

  3. 3 Posted by shortfinals on 27 Jun, 2013 05:03 PM

    shortfinals's Avatar

    I tried again and again, OS. Now OTHER rec's won't take, not only yours, plus several other major problems

    SF

  4. 4 Posted by Glen The Plumbe... on 27 Jun, 2013 09:00 PM

    Glen The Plumber's Avatar

    I found the problem...with help.

    in the code...add "http:" in front of "//www"

  5. 5 Posted by Otteray Scribe on 28 Jun, 2013 12:26 AM

    Otteray Scribe's Avatar

    Glen, I tried that. //www appears twice in the embed code. I tried putting http: in front of both, but apparently needs to only be in front of the second //www. That seemed to work.

    Still does not answer why SF is having trouble giving recs to comments or why he is having diary posting problems.

  6. 6 Posted by Glen The Plumbe... on 28 Jun, 2013 12:39 AM

    Glen The Plumber's Avatar

    yes...you are using the "old embed" code...in the new code the URL is only listed once.

    no insight on SF's problems...but have had problem with comment recs not 'sticking'...must click a few times before it takes.

  7. 7 Posted by Otteray Scribe on 28 Jun, 2013 12:56 AM

    Otteray Scribe's Avatar

    Some videos don't give you a choice of old or new code. The one I referenced in my first comment only had the old code.

  8. 8 Posted by SouthernLiberal... on 28 Jun, 2013 02:15 AM

    SouthernLiberalinMD's Avatar

    And now my comment to this discussion has also disappeared.

    Any chance for more help on this issue, because I've inserted "http" and it doesn't help.

  9. 9 Posted by Otteray Scribe on 28 Jun, 2013 02:25 AM

    Otteray Scribe's Avatar

    Did you remember to put in the colon? Has to be http: in front of the //www. for it to work.

  10. 10 Posted by Glen The Plumbe... on 28 Jun, 2013 02:58 AM

    Glen The Plumber's Avatar
  11. 11 Posted by Otteray Scribe on 28 Jun, 2013 04:35 AM

    Otteray Scribe's Avatar

    Here is a diary on the subject. elfling has a comment and explanation in it.

    http://www.dailykos.com/story/2013/06/27/1219567/-Video-Embedding-Tip-Reference-to-Earlier-Diary

  12. 12 Posted by msmacgyver on 28 Jun, 2013 04:58 AM

    msmacgyver's Avatar

    Thursday night: also cannot embed youtube vids.

  13. 13 Posted by shortfinals on 28 Jun, 2013 11:09 AM

    shortfinals's Avatar

    I concur regarding the inability to embed YouTube vids. My ability to make recs is somewhat improved

  14. 14 Posted by SouthernLiberal... on 28 Jun, 2013 04:25 PM

    SouthernLiberalinMD's Avatar

    Got it. Thanks!

  15. Support Staff 15 Posted by elfling on 28 Jun, 2013 10:48 PM

    elfling's Avatar

    Here is the deal with embeds:

    YouTube thoughtfully changed their embed code Thursday in such a way that embeds are breaking on our site.

    We have a fix in place that will go up monday. In the meantime, if you use video, you'll have to follow this extra step for your video to show:

    Copy the embed code, for example:

    <div class="dkimg-c"><iframe width="550" height="309" src="//www.youtube.com/embed/fsszNpUAb-U" frameborder="0" allowfullscreen></iframe></div>

    Change it to

    <div class="dkimg-c"><iframe width="550" height="309" src="http://www.youtube.com/embed/fsszNpUAb-U" frameborder="0" allowfullscreen></iframe></div>

    did you catch that?

    after the src=

    change

    src="// to
    src="http://

    IE: when you preview your story, or your comment, and you see a big blank spot where you thought a video would be, that is real, not your browser f'ing up. No video will be shown.

    Thanks all, and sorry for the inconvenience.

  16. elfling closed this discussion on 28 Jun, 2013 10:48 PM.

  17. elfling re-opened this discussion on 28 Jun, 2013 10:48 PM

  18. 16 Posted by aoeu on 30 Jun, 2013 05:51 PM

    aoeu's Avatar

    Out of curiosity will currently missing vids appear on Monday and is the tag librarian change staged for then?

  19. Support Staff 17 Posted by elfling on 01 Jul, 2013 06:10 PM

    elfling's Avatar

    No, missing vids will not come back, because what has happened is that the Scary Code detector has scrubbed them out.

    The tag librarian change is waiting for a big enormous code change and will go in when that one does. Ideally it would be ready today or tomorrow but we won't push that whole tangle unless it's all ready AND unless the next day is a work day when all hands are here. It's annoying when there are so many dependencies that get hooked together!

    The video piece can be cherry-picked out if need be. It certainly cannot wait.

  20. elfling closed this discussion on 01 Jul, 2013 06:10 PM.

  21. elfling re-opened this discussion on 03 Jul, 2013 08:52 PM

  22. Support Staff 18 Posted by elfling on 03 Jul, 2013 08:52 PM

    elfling's Avatar

    Fix for this is up and running. Please let me know if you have trouble in the future.

    Note that some settings you can chose from Youtube can create the problem as well. This works for sure:

  23. elfling closed this discussion on 03 Jul, 2013 08:53 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac